HTTP response code 400
400 - Content not in expected format
Cause
This error is returned when the workflow’s input message is in the wrong format, such as:
-
Incorrect
Message Format
is set on the workflow trigger.For example, when this is set to “XML” but the request body is formatted in JSON.
-
Request Body data is in the wrong format.
For example, when the
Message Format
expects XML but the Request Body supplies JSON.
Resolution
To resolve:
-
In Saltbox, go to the Workflow Trigger page.
-
Inspect the setting: Raw Message Contents > Message Format. If this is not as expected, update this setting (for example, change “XML” to “JSON” or vice versa).
-
Inspect the request data. If this is not as expected, correct the data.
-
If the Message Format workflow trigger setting and request data do not match, this error will result. If there are scenarios where multiple formats are supported, these must be set up as separate triggers.