HTTP response code 400

400 - Content not in expected format

Cause

This error is returned when the workflow’s input message is in the wrong format, such as:

Resolution

To resolve:

  1. In Saltbox, go to the Workflow Trigger page.

  2. Inspect the setting: Raw Message Contents > Message Format. If this is not as expected, update this setting (for example, change “XML” to “JSON” or vice versa).

  3. Inspect the request data. If this is not as expected, correct the data.

  4. If the Message Format workflow trigger setting and request data do not match, this error will result. If there are scenarios where multiple formats are supported, these must be set up as separate triggers.